Project

General

Profile

[logo] 
 
Home
News
Activity
About/Contact
Major Tools
  Dinotrace
  Verilator
  Verilog-mode
  Verilog-Perl
Other Tools
  IPC::Locker
  Parallel::Forker
  Voneline
General Info
  Papers

make install

Added by Stefan Wallentowitz almost 10 years ago

Hi,

I did the following (usual) steps:
./configure --prefix=/opt/verilator
make
make install

The last seems suspicious: - it produces a slight error (/usr/bin/install: cannot stat `test_sp/*.[chv]*': No such file or directory) - at the end it tells me to set the VERILATOR_ROOT to the current dir - that finally ends me up in a weird environment when setting VERILATOR_ROOT to /opt/verilator instead of my git clone dir.

It seems like the install (that produces bin/ and share/ at target) does not work as intended.

Can anybody confirm this problems or did I miss something? In case it is a problem, I will try to provide a patch..

Bye, Stefan


Replies (6)

RE: make install - Added by Wilson Snyder almost 10 years ago

I was able to reproduce this, but it required running configure from "outside" the source tree. Can you confirm that's what you really did (ie "srcdir/configure")?

Anyhow I fixed that in the git version.

RE: make install - Added by Stefan Wallentowitz almost 10 years ago

First of all, thanks for your very fast reply.

I pulled the new version, but it seems the main issue is not in the install, but in the program itself. By the way: I run the orpsocv2 from opencores.org. After installation the tree looks like this:
+-bin/
| |-verilator
| |-verilator_bin
| |-verilator_bin_dgb
| |-verilator_profcfunc
+-share/
  |-man/..
  |-verilator/
    |-bin/
    | |-verilator_includer
    |-examples/..
    |-include
      |-verilated.mk
      |-*.cpp,*.h
After the step "Generating makefiles with Verilator", that is
verilator -language 1364-2001 -Wno-lint --top-module orpsoc_top  -Mdir . -sc -trace -I.. -f verilator.scr.generated

Verilator creates the Makefile and at the end includes the verilated.mk, that is

# Include global rules
include $(VERILATOR_ROOT)/include/verilated.mk

Apparently with the given path from above $VERILATOR_ROOT/share/verilator/include/verilated.mk would be the correct path, assuming VERILATOR_ROOT should point to the base to the tree. Setting VERILATOR_ROOT to $VERILATOR_ROOT/share/verilator/ does also break verilator:

Can't exec "/my/path/to/installation/share/verilator//verilator_bin": No such file or directory at /my/path/to/installation/bin//verilator line 130.
%Error: verilator: Misinstalled, or VERILATOR_ROOT might need to be in environment

I will go on as suggested, that is having the git-repository on our installation server, but maybe you can check this again for future releases.

Thanks for your great work!

Bye, Stefan

RE: make install - Added by Wilson Snyder almost 10 years ago

Since you're pulling from git, you're running autoconf, which I think is different from mine. Can you attach the ./configure it generates? Thanks.

RE: make install - Added by Stefan Wallentowitz almost 10 years ago

Ah, okay, that might be a reason. I run Ubuntu 9.10 32-bit. I attached the configure script.

Thanks!

configure (148 KB)

RE: make install - Added by Philipp Wagner over 4 years ago

Look there ... it's 5 years later and I'm running into the same issue as Stefan -- just this time with a solution :-)

Actually I think it's just a documentation problem. The README.pod says for the "module" install:

After installing you'll want a module file like the following:

set install_root /CAD_DISK/verilator/{version-number-used-above}
setenv VERILATOR_ROOT $install_root
prepend-path PATH $install_root/bin
prepend-path MANPATH $install_root/man
Further down, the README says:
If you used the prefix scheme, now do a C<make install>.  To run verilator,
have the verilator binary directory in your PATH (this should already be
true if using the default configure), and make sure VERILATOR_ROOT is not
set.

So essentially just not setting VERILATOR_ROOT in the module file solves the problem.

A patch is attached, which additionally adds the pkg-config path as a drive-by.

verilator-readme.patch View - README.pod patch (539 Bytes)

RE: make install - Added by Wilson Snyder over 4 years ago

Great! This is pushed to git towards 3.877.

    (1-6/6)