Project

General

Profile

[logo] 
 
Home
News
Activity
About/Contact
Major Tools
  Dinotrace
  Verilator
  Verilog-mode
  Verilog-Perl
Other Tools
  BugVise
  CovVise
  Force-Gate-Sim
  Gspice
  IPC::Locker
  Rsvn
  SVN::S4
  Voneline
  WFH
General Info
  Papers

How to disable MULTITOP?

Added by Ignatius Rivaldi 5 months ago

I'm using Verilator as a linter (actually its this plugin: https://atom.io/packages/linter-verilator) as the other verilog linter plugin that is based on icarus verilog failed to work for some reason. Every time I edit a Verilog library file, my linter plugin shows MULTITOP error, which is not really an error, because I'm editing a library file not a testbench file, and it is annoying and spams Atom with a lot of 'errors'. For code organization, I don't want to make each module in a separate file, and because this is a editor linter, I can't just pass a -v into verilator. Is there a way to stop this message and/or to declare this file as a library inside the code itself, like verilator lint_off?


Replies (2)

RE: How to disable MULTITOP? - Added by Wilson Snyder 5 months ago

You can specify a --top-module option and it won't lint the other modules. But I think what you really want is some set of flags that will work to lint any file? I can look at adding an option to wrap multiple top modules, but it will only make sense for linting.

RE: How to disable MULTITOP? - Added by Wilson Snyder about 1 month ago

Note the code in git and next version 4.018 will allow multiple top files - see the documentation.

    (1-2/2)