Project

General

Profile

[logo] 
 
Home
News
Activity
About/Contact
Major Tools
  Dinotrace
  Verilator
  Verilog-mode
  Verilog-Perl
Other Tools
  BugVise
  CovVise
  Force-Gate-Sim
  Gspice
  IPC::Locker
  Rsvn
  SVN::S4
  Voneline
  WFH
General Info
  Papers

trying to run the tests

Added by Bryan Murdok 6 months ago

I'm concerned that not all the tests are running when I run make in the test_regress directory. It doesn't run for very long and the summary is this:

*-* All Finished *-*
- t/t_EXAMPLE.v:71: Verilog $finish
vlt/t_EXAMPLE: Self PASSED

I was curious to try a different simulator, so I did this:

$ ./driver.pl --iverilog
======================================================================
/t_EXAMPLE: ==================================================
-Skip: /t_EXAMPLE: scenario '' not enabled for test
/t_EXAMPLE: %Skip: Skip: scenario '' not enabled for test

Even more curious, I tried this:

$ ./driver.pl --blarg
======================================================================
dist/t_EXAMPLE: ==================================================
-Skip: dist/t_EXAMPLE: scenario 'dist' not enabled for test
dist/t_EXAMPLE: %Skip: Skip: scenario 'dist' not enabled for test

Something doesn't feel right. I'm using git, latest master: 4f98f84da96e065200f26fc7d5d8168ccca08035

Bryan


Replies (7)

RE: trying to run the tests - Added by Wilson Snyder 6 months ago

Use

./configure --enable-longtests

See the internals.* documentation for more information.

RE: trying to run the tests - Added by Enzo Chi 17 days ago

I did the configuration with this command
    ./configure --enable-longtests

But when I run "make test"

It doesn't run the regression tests and here is the output message:

/Library/Developer/CommandLineTools/usr/bin/make -C test_regress
/usr/bin/perl driver.pl -j 0 --vlt --vltmt --dist
driver.pl: Found 8 cores, using -j 9
== Many jobs; redirecting STDIN
======================================================================
dist/t_EXAMPLE: ==================================================
-Skip: dist/t_EXAMPLE: scenario 'dist' not enabled for test
dist/t_EXAMPLE: %Skip: Skip: scenario 'dist' not enabled for test
Tests passed!

RE: trying to run the tests - Added by Wilson Snyder 17 days ago

The first lines are correct. Nothing at all after that?

RE: trying to run the tests - Added by Enzo Chi 17 days ago

That's all I got.

RE: trying to run the tests - Added by Wilson Snyder 17 days ago

Perhaps the perl IPC::Forker package is exiting early, is there something special about your system like weird security settings?

You can comment out this line, though it'll make tests take 9 times longer.

diff --git a/test_regress/driver.pl b/test_regress/driver.pl
index 7de2310e..db952722 100755
--- a/test_regress/driver.pl
+++ b/test_regress/driver.pl
@@ -28,7 +28,7 @@ use lib ".";
 $::Driver = 1;
 $::Have_Forker = 0;

-eval "use Parallel::Forker; \$Fork=Parallel::Forker->new(use_sig_child=>1); \$::Have_Forker=1;";
+#eval "use Parallel::Forker; \$Fork=Parallel::Forker->new(use_sig_child=>1); \$::Have_Forker=1;";
 $Fork = Forker->new(use_sig_child=>1) if !$Fork;
 $SIG{CHLD} = sub { $Fork->sig_child() if $Fork; };
 $SIG{TERM} = sub { $Fork->kill_tree_all('TERM') if $Fork; die "Quitting...\n"; };

RE: trying to run the tests - Added by Enzo Chi 14 days ago

I have tried that, can't see any changes. All the same. I have attached the LOG files. Hope it will be helpful

comp.log View - make command log (92 KB)

conf.log View - ./configure command log (3.74 KB)

config.log View (60.7 KB)

test.log View - make test command log (20.1 KB)

RE: trying to run the tests - Added by Wilson Snyder 14 days ago

See what was wrong, this should be fixed in git, thanks for the bug report & debugging.

Note you should cpan install Parallel::Forker for better testing, it will now also tell you this.

    (1-7/7)