Project

General

Profile

[logo] 
 
Home
News
Activity
About/Contact
Major Tools
  Dinotrace
  Verilator
  Verilog-mode
  Verilog-Perl
Other Tools
  BugVise
  CovVise
  Force-Gate-Sim
  Gspice
  IPC::Locker
  Rsvn
  SVN::S4
  Voneline
  WFH
General Info
  Papers

Issue #1232

configure check for -faligned-new needs to include header

Added by Jeff Bush over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Configure/Make/Compiling
% Done:

0%


Description

There is a check in the configure script to see if -faligned-new works correctly. The test program looks like this:

int
main ()
{
    int* a=new int;
    delete a;
}

If I run this program on MacOS 10.12.6 with command line tools 9.0, it links correctly. However, if I include the header <new> at the top, it will fail:

Undefined symbols for architecture x86_64:
  "operator delete(void*, std::align_val_t)", referenced from:
      _main in foo-779f7f.o

So, the problem is that the test program passes, but then verilator fails to link because it does pull in the <new> header. The configure test program should probably include this header.

History

#1 Updated by Wilson Snyder over 1 year ago

  • Category set to Configure/Make/Compiling
  • Status changed from New to Resolved
  • Assignee set to Wilson Snyder

Please give git a try.

Fixed in git (I hope) towards 3.916.

#2 Updated by Jeff Bush over 1 year ago

That fixes it, thanks for the quick turnaround!

checking whether g++ accepts -faligned-new... no

...

Build complete!

Now type 'make test' to test.

#3 Updated by Wilson Snyder about 1 year ago

  • Status changed from Resolved to Closed

In 3.916.

Also available in: Atom