Project

General

Profile

[logo] 
 
Home
News
Activity
About/Contact
Major Tools
  Dinotrace
  Verilator
  Verilog-mode
  Verilog-Perl
Other Tools
  BugVise
  CovVise
  Force-Gate-Sim
  Gspice
  IPC::Locker
  Rsvn
  SVN::S4
  Voneline
  WFH
General Info
  Papers

Issue #1256

example/trace_sc doesn't compile with SystemC 2.3.2

Added by Enzo Chi over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
-
% Done:

0%


Description

I have installed SystemC 2.3.2 and Verilator 3.916. All the example/xxx work fine except the `tracing_sc`. I got compile error as below

make

-- Verilator tracing example

-- VERILATE ----------------
verilator  -sc --exe -O2 -x-assign 0 -Wall --trace --assert --coverage -f input.vc top.v sc_main.cpp

-- COMPILE ----------------=
make -j 4 -C obj_dir -f ../Makefile_obj
make[1]: Entering directory `/opt/ec_data/ec_workspace/App/share/verilator/examples/tracing_sc/obj_dir'
make[1]: warning: -jN forced in submake: disabling jobserver mode.
/opt/imc/gcc-6.2.0/bin/g++  -I.  -MMD -I/export/home/echi/App/share/verilator/include -I/export/home/echi/App/share/verilator/include/vltstd -DVL_PRINTF=printf -DVM_COVERAGE=1 -DVM_SC=1 -DVM_TRACE=1 -Wno-sign-compare -Wno-uninitialized -Wno-unused-but-set-variable -Wno-unused-parameter -Wno-unused-variable -Wno-shadow      -pthread -I/export/home/echi/App/systemc/include -MMD -MP -DVL_DEBUG=1 -Wno-deprecated -O2 -fstrict-aliasing -c -o sc_main.o ../sc_main.cpp
/opt/imc/gcc-6.2.0/bin/g++  -I.  -MMD -I/export/home/echi/App/share/verilator/include -I/export/home/echi/App/share/verilator/include/vltstd -DVL_PRINTF=printf -DVM_COVERAGE=1 -DVM_SC=1 -DVM_TRACE=1 -Wno-sign-compare -Wno-uninitialized -Wno-unused-but-set-variable -Wno-unused-parameter -Wno-unused-variable -Wno-shadow      -pthread -I/export/home/echi/App/systemc/include -MMD -MP -DVL_DEBUG=1 -Wno-deprecated  -c -o verilated.o /export/home/echi/App/share/verilator/include/verilated.cpp
/opt/imc/gcc-6.2.0/bin/g++  -I.  -MMD -I/export/home/echi/App/share/verilator/include -I/export/home/echi/App/share/verilator/include/vltstd -DVL_PRINTF=printf -DVM_COVERAGE=1 -DVM_SC=1 -DVM_TRACE=1 -Wno-sign-compare -Wno-uninitialized -Wno-unused-but-set-variable -Wno-unused-parameter -Wno-unused-variable -Wno-shadow      -pthread -I/export/home/echi/App/systemc/include -MMD -MP -DVL_DEBUG=1 -Wno-deprecated  -c -o verilated_cov.o /export/home/echi/App/share/verilator/include/verilated_cov.cpp
/opt/imc/gcc-6.2.0/bin/g++  -I.  -MMD -I/export/home/echi/App/share/verilator/include -I/export/home/echi/App/share/verilator/include/vltstd -DVL_PRINTF=printf -DVM_COVERAGE=1 -DVM_SC=1 -DVM_TRACE=1 -Wno-sign-compare -Wno-uninitialized -Wno-unused-but-set-variable -Wno-unused-parameter -Wno-unused-variable -Wno-shadow      -pthread -I/export/home/echi/App/systemc/include -MMD -MP -DVL_DEBUG=1 -Wno-deprecated  -c -o verilated_vcd_c.o /export/home/echi/App/share/verilator/include/verilated_vcd_c.cpp
/opt/imc/gcc-6.2.0/bin/g++  -I.  -MMD -I/export/home/echi/App/share/verilator/include -I/export/home/echi/App/share/verilator/include/vltstd -DVL_PRINTF=printf -DVM_COVERAGE=1 -DVM_SC=1 -DVM_TRACE=1 -Wno-sign-compare -Wno-uninitialized -Wno-unused-but-set-variable -Wno-unused-parameter -Wno-unused-variable -Wno-shadow      -pthread -I/export/home/echi/App/systemc/include -MMD -MP -DVL_DEBUG=1 -Wno-deprecated  -c -o verilated_vcd_sc.o /export/home/echi/App/share/verilator/include/verilated_vcd_sc.cpp
../sc_main.cpp: In function ‘int sc_main(int, char**)’:
../sc_main.cpp:97:35: error: invalid new-expression of abstract class type ‘VerilatedVcdSc’
         VerilatedVcdSc* tfp = new VerilatedVcdSc;
                                   ^~~~~~~~~~~~~~
In file included from ../sc_main.cpp:14:0:
/export/home/echi/App/share/verilator/include/verilated_vcd_sc.h:38:7: note:   because the following virtual functions are pure within ‘VerilatedVcdSc’:
 class VerilatedVcdSc
       ^~~~~~~~~~~~~~
In file included from /export/home/echi/App/systemc/include/sysc/communication/sc_signal.h:40:0,
                 from /export/home/echi/App/systemc/include/sysc/communication/sc_buffer.h:34,
                 from /export/home/echi/App/systemc/include/systemc:79,
                 from /export/home/echi/App/systemc/include/systemc.h:219,
                 from ../sc_main.cpp:9:
/export/home/echi/App/systemc/include/sysc/tracing/sc_trace.h:97:18: note:      virtual void sc_core::sc_trace_file::trace(const sc_core::sc_event&, const string&)
     virtual void trace( const tp& object,                                     \
                  ^
/export/home/echi/App/systemc/include/sysc/tracing/sc_trace.h:106:5: note: in expansion of macro ‘DECL_TRACE_METHOD_A’
     DECL_TRACE_METHOD_A( sc_event )
     ^~~~~~~~~~~~~~~~~~~
/export/home/echi/App/systemc/include/sysc/tracing/sc_trace.h:97:18: note:      virtual void sc_core::sc_trace_file::trace(const sc_core::sc_time&, const string&)
     virtual void trace( const tp& object,                                     \
                  ^
/export/home/echi/App/systemc/include/sysc/tracing/sc_trace.h:107:5: note: in expansion of macro ‘DECL_TRACE_METHOD_A’
     DECL_TRACE_METHOD_A( sc_time )
     ^~~~~~~~~~~~~~~~~~~
/usr/bin/perl /export/home/echi/App/share/verilator/bin/verilator_includer -DVL_INCLUDE_OPT=include Vtop.cpp > Vtop__ALLcls.cpp
/usr/bin/perl /export/home/echi/App/share/verilator/bin/verilator_includer -DVL_INCLUDE_OPT=include Vtop__Trace.cpp Vtop__Syms.cpp Vtop__Trace__Slow.cpp > Vtop__ALLsup.cpp
/opt/imc/gcc-6.2.0/bin/g++  -I.  -MMD -I/export/home/echi/App/share/verilator/include -I/export/home/echi/App/share/verilator/include/vltstd -DVL_PRINTF=printf -DVM_COVERAGE=1 -DVM_SC=1 -DVM_TRACE=1 -Wno-sign-compare -Wno-uninitialized -Wno-unused-but-set-variable -Wno-unused-parameter -Wno-unused-variable -Wno-shadow      -pthread -I/export/home/echi/App/systemc/include -MMD -MP -DVL_DEBUG=1 -Wno-deprecated -O2 -fstrict-aliasing -c -o Vtop__ALLcls.o Vtop__ALLcls.cpp
/opt/imc/gcc-6.2.0/bin/g++  -I.  -MMD -I/export/home/echi/App/share/verilator/include -I/export/home/echi/App/share/verilator/include/vltstd -DVL_PRINTF=printf -DVM_COVERAGE=1 -DVM_SC=1 -DVM_TRACE=1 -Wno-sign-compare -Wno-uninitialized -Wno-unused-but-set-variable -Wno-unused-parameter -Wno-unused-variable -Wno-shadow      -pthread -I/export/home/echi/App/systemc/include -MMD -MP -DVL_DEBUG=1 -Wno-deprecated  -c -o Vtop__ALLsup.o Vtop__ALLsup.cpp
make[1]: *** [sc_main.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/opt/ec_data/ec_workspace/App/share/verilator/examples/tracing_sc/obj_dir'
make: *** [run] Error 2

History

#1 Updated by Wilson Snyder over 1 year ago

  • Status changed from New to Duplicate

Presumably a duplicate of bug1251 which is fixed in git but not released yet (will release tomorrowish).

Also available in: Atom