Project

General

Profile

[logo] 
 
Home
News
Activity
About/Contact
Major Tools
  Dinotrace
  Verilator
  Verilog-mode
  Verilog-Perl
Other Tools
  BugVise
  CovVise
  Force-Gate-Sim
  Gspice
  IPC::Locker
  Rsvn
  SVN::S4
  Voneline
  WFH
General Info
  Papers

Issue #1289

scr1 test suite: string.hextoa is not implemented

Added by Joel Holdsworth 9 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Unsupported
% Done:

0%


Description

The follow code SystemVerilog code fails to build...
module test();

string mystring;
logic [31:0] myinteger = 'h012345678;

initial begin
  mystring.hextoa(myinteger);
end

endmodule

...with the following errors...

%Error: test_hextoa.sv:8: Unsupported: built-in string method 'VARREF 'mystring''
%Error: Exiting due to 1 error(s)
%Error: See the manual and http://www.veripool.org/verilator for more assistance.
%Error: Command Failed /usr/local/bin/verilator_bin -sv --cc test_hextoa.sv

string.hextoa() is currently not implemented.

History

#1 Updated by Wilson Snyder 9 months ago

Perhaps you would like to attempt a patch? First make a test case (see internals.txt) which passes on another simulator you can start with one of the existing tests. Then fix V3Width to decode the method, I suspect it can just become a hardcoded-formatted AstSFormatF - basically a $sformat.

#2 Updated by Wilson Snyder 9 months ago

  • Status changed from New to Confirmed

#3 Updated by Joel Holdsworth 9 months ago

Sure, I don't mind having a look.

#4 Updated by Wilson Snyder 4 months ago

  • Status changed from Confirmed to Resolved

Fixed in git towards 4.000. Added itoa, octtoa, hextoa, bintoa, realtoa.

#5 Updated by Wilson Snyder 3 months ago

  • Status changed from Resolved to Closed

In 4.002.

Also available in: Atom