Project

General

Profile

[logo] 
 
Home
News
Activity
About/Contact
Major Tools
  Dinotrace
  Verilator
  Verilog-mode
  Verilog-Perl
Other Tools
  BugVise
  CovVise
  Force-Gate-Sim
  Gspice
  IPC::Locker
  Rsvn
  SVN::S4
  Voneline
  WFH
General Info
  Papers

Issue #1345

String conditional operation gives compile error

Added by Iztok Jeras 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
TranslationError
% Done:

0%


Description

This is an error compiling generated C++ code. I assume it is related to SV string type functionality, but it could be something else.

I tried to make the test case smaller (it is now about 20 lines), but if I remove additional lines of code the code compiles and runs properly. Verilator Git HEAD from a couple of days ago was used.

I attached a tarball containing the example and generated code. To reproduce the issue do:

tar -xvf bugreport.tgz
cd bugreport/sim
export VERILATOR_ROOT=???
make

Regards, Iztok Jeras

History

#1 Updated by Wilson Snyder 3 months ago

  • Subject changed from compile error in generated C++ files, probably SV string related to String conditional operation gives compile error
  • Category set to TranslationError
  • Status changed from New to Resolved
  • Assignee set to Wilson Snyder

The problem is related to conditional ? : operators not propagating the string type.

Fixed in git towards 4.000.

#2 Updated by Wilson Snyder 3 months ago

  • Status changed from Resolved to Closed

In 4.002.

Also available in: Atom