Project

General

Profile

[logo] 
 
Home
News
Activity
About/Contact
Major Tools
  Dinotrace
  Verilator
  Verilog-mode
  Verilog-Perl
Other Tools
  BugVise
  CovVise
  Force-Gate-Sim
  Gspice
  IPC::Locker
  Rsvn
  SVN::S4
  Voneline
  WFH
General Info
  Papers

Issue #1441

incorrect handling of strings in display and sformatf

Added by Denis Rystsov 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
WrongRuntimeResult
% Done:

0%


Description

$display of a string parameter or an expression with type string produces incorrect result in certain cases. Please see the attached test case cases 2 and 4.

t_display_string.pl View (518 Bytes) Denis Rystsov, 05/15/2019 02:51 PM

t_display_string.v (545 Bytes) Denis Rystsov, 05/15/2019 02:51 PM

t_display_string.out (77 Bytes) Denis Rystsov, 05/15/2019 02:51 PM

History

#1 Updated by Wilson Snyder 4 months ago

  • Status changed from New to Confirmed
  • Assignee set to Wilson Snyder

Thanks for putting this in test_regress format, that helps.

First bug is at present it assumes %h when no display format provided. Second bug is loss of string when constant propagated in parameter; note however some other simulators don't allow $sformatf in constant functions (Verilator intended to support it however).

Will look at a fix this weekend.

#2 Updated by Wilson Snyder 4 months ago

  • Status changed from Confirmed to Resolved

Both issues fixed in git towards 4.015.

#3 Updated by Wilson Snyder 3 months ago

  • Status changed from Resolved to Closed

In 4.016.

Also available in: Atom