Project

General

Profile

[logo] 
 
Home
News
Activity
About/Contact
Major Tools
  Dinotrace
  Verilator
  Verilog-mode
  Verilog-Perl
Other Tools
  BugVise
  CovVise
  Force-Gate-Sim
  Gspice
  IPC::Locker
  Rsvn
  SVN::S4
  Voneline
  WFH
General Info
  Papers

Issue #1484

Parameter of an array of enumeration values breaks conditionals inside a generate block

Added by John Martin about 2 months ago. Updated about 2 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
% Done:

0%


Description

This was tested using the Verilator 4.016 release. When using a parameter that is an array of enumeration values inside an if (or case) condition of a generate block triggers the following errors: %Error: test.sv:48: Illegal assignment of constant to unpacked array %Error: test.sv:48: Generate If condition must evaluate to constant

When changing the array to be packed Verilator will throw only warnings; however the generate block does not evaluate the condition correctly. Attached is a test case that demonstrates this. The example simulates correctly with Incisive and synthesizes with Design Compiler. Icarus Verilog and Yosys unfortunately don't support this syntax.

verilator_test.zip (1.76 KB) John Martin, 07/30/2019 07:21 PM

History

#1 Updated by Wilson Snyder about 2 months ago

  • Status changed from New to Duplicate

Thanks for the report & test. This is a duplicate of bug1315, on which work is currently in progress.

Also available in: Atom