Project

General

Profile

[logo] 
 
Home
News
Activity
About/Contact
Major Tools
  Dinotrace
  Verilator
  Verilog-mode
  Verilog-Perl
Other Tools
  IPC::Locker
  Parallel::Forker
  Voneline
General Info
  Papers

Issue #1618

Travis Mail not going to authors?

Added by Wilson Snyder 8 days ago. Updated 3 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Tests
% Done:

0%


Description

Re issue 1617:

BTW, something, maybe your email-yourself?, seems to have broken the author of the commit getting email on the breakage, so I hadn't noticed. Perhaps ideal behavior would be both of us get all fails, plus the author?

History

#1 Updated by Todd Strader 8 days ago

  • Status changed from New to Confirmed

You're right. The default Travis behavior is to email the author and committer. But if you specify an email recipients list, that replaces the default recipients (which was not the intended effect). It also doesn't appear that you can extend the recipient list instead of replacing it. I agree that we should be able to get emails going to the author + a list of interested individuals.

For now, I'll band-aid it by adding you to the list. I'll check with the Travis folks to see if there is a more elegant solution, but I may have to go to something more involved like webhooks. Hopefully not.

#2 Updated by Wilson Snyder 8 days ago

If travis has nothing to fix this, perhaps instead of overriding email, have a end-of-run script that simply does a sendmail to us passing the relevant build URL?

#3 Updated by Wilson Snyder 3 days ago

Todd, Email working, can this be closed, or more to do?

#4 Updated by Todd Strader 3 days ago

Yeah, it mostly works now. Currently, you and I will get emails on any failures or transitions from failing to passing. But authors and committers are not getting emails at present. Ideally we'd be able to add our list of recipients to the default of author and committer, but I'm told Travis can't do that.

I can try your suggestion of manually emailing on failure so that authors and committers still get emails. The only problem with that is that people (mainly you) will get twice the email if they are both the committer and on the recipient list. Also, it (probably) won't be stateful so we wouldn't get the failing -> passing emails.

At this point I'm inclined to say this is good enough because if someone else breaks the build we can/will let them know. Also, if they had CI running on their fork, they'd have already gotten an email. Thoughts?

#5 Updated by Wilson Snyder 3 days ago

  • Status changed from Confirmed to Closed

Seems reasonable for now, we can get fancier later if need to.

Also available in: Atom