Project

General

Profile

[logo] 
 
Home
News
Activity
About/Contact
Major Tools
  Dinotrace
  Verilator
  Verilog-mode
  Verilog-Perl
Other Tools
  BugVise
  CovVise
  Force-Gate-Sim
  Gspice
  IPC::Locker
  Rsvn
  SVN::S4
  Voneline
  WFH
General Info
  Papers

Issue #385

Dpi exported tasks with array inputs don't compile.

Added by Thomas Watts almost 8 years ago. Updated 23 days ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Unsupported
% Done:

0%


Description

Compiling the following with verilator --lint_only gives the error message

Unsupported: Assignment between packed arrays of different dimensions

   export "DPI-C" task dpi_bytes;
   task dpi_bytes;
      input byte bytes [1:0];
   endtask

I've also tried declaring an input string (which admittedly is documented as unsupported).

Are there any plans to support this sort of thing, or any workarounds?

Thanks, Tom.

History

#1 Updated by Wilson Snyder almost 8 years ago

Are you trying to pass a string? Strings aren't represented as an array of bytes in verilog, but rather one long number, so you'd do this

task dpi_bytes; input field [2*8-1:0];

Then in C you'd need to convert the null terminated string to the proper width. Or use a SystemVerilog string, but ;)

As for the original question, there isn't any array support across the DPI yet. If that is really what you're trying to do, and this example code works in other simulators, it shouldn't be too hard, let me know and I'll look.

#2 Updated by Thomas Watts almost 8 years ago

I'm actually trying to pass a transaction of 10s of bytes from C to Verilog. I was hoping to assemble the bytes in a C char array and pass through the DPI to a System Verilog array of bytes. Although using a string or large vector wouldn't be too difficult as you suggest.

However I can't get any of these three approaches to work with Verilator. 2-D arrays get the message as described in the original bug report, strings and vectors larger than 32-bits are unsupported.

I am developing this code to be portable and it does work in another simulator. I pass the dpi function a const char * and can index the bytes in System Verilog.

Let me know if I can help with testcases or beta testing.

#3 Updated by Wilson Snyder almost 8 years ago

  • Category set to Unsupported
  • Status changed from New to Assigned
  • Assignee set to Wilson Snyder

DPI exports of wide vectors should be supported, there's a test case in test_regress/t/t_dpi_export.v; if you could modify that file to show the failure and to show an example of what you'd like I'll do what I can. (Run it with test_regress/t/t_dpi_export.pl [--vcs] [--nc])

#4 Updated by Thomas Watts almost 8 years ago

I was using 3.812, updating to 3.820 fixes large vectors. So I have things working with packing / unpacking across the dpi call.

The passing of arrays would be useful, as it would be much cleaner, but can be worked around.

#5 Updated by Wilson Snyder over 7 years ago

  • Status changed from Assigned to Feature
  • Priority changed from Normal to Low

Have workaround; revisit when data type changes in.

#6 Updated by Guy Hutchison about 7 years ago

I'd like to bump this as a requested feature; I'm working on a driver where passing variable-length data would be very helpful, of the form:

integer nq_insert_packet (input string qname, input bit [7:0] in_pkt[]);

#7 Updated by Wilson Snyder about 7 years ago

I'm not actively working on DPI improvements, so there will be a good wait. If you would like to try to make the improvements yourself, this would be greatly appreciated, and I can provide pointers.

#8 Updated by Wilson Snyder 23 days ago

  • Status changed from Feature to Closed

Forgot to close; open array support was added in 3.918 2018-01-02.

Also available in: Atom